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IMPORTANT PRODUCT INFORMATION

 READ THIS INFORMATION FIRST

Product: VersaPro™ Programming Software Release 1.10

IC641VPS300D VersaPro - Windows Programming software for Series 90™-30 and VersaMax™ PLCs

IC641VPS002A VersaPro - Windows Programming software for Series 90 Micro, VersaMax Nano/Micro
PLCs

IC640VPS002A VersaPro - Windows Programming software for Series 90 Micro, VersaMax Nano/Micro
PLCs with cable

IC641VUG300D VersaPro Upgrade for Series 90-30 and VersaMax PLCs

IC641VPH300D VersaPro - Windows Programming software for Series 90-30 and VersaMax PLCs with SNP
Cable

IC641VUG301D Logicmaster 90-30 Subscription to VersaPro Upgrade - Via Direct Mail Coupon

IC641VPS305D VersaPro 5 Pack - Windows Programming software for Series 90-30 and VersaMax PLCs

IC641VPS310D VersaPro 10 Pack - Windows Programming software for Series 90-30 and VersaMax PLCs

IC641VPS325D VersaPro 25 Pack - Windows Programming software for Series 90-30 and VersaMax PLCs

IC641VPS350D VersaPro 50 Pack - Windows Programming software for Series 90-30 and VersaMax PLCs

IC641VPD010D VersaPro Distributor Demo 10 Pack

IC641VPD050D VersaPro Distributor Demo 50 Pack

IC641VPP050D VersaPro Media Kit - 50 Pack

Caution

You should back up VersaPro 1.0x folders before installing VersaPro 1.10 because saving any of
these folders with VersaPro 1.10 will prevent the folder from being used with VersaPro 1.0x.

Caution

When using the 90-30 Profibus Master Module (HE693PBM101) with VersaPro 1.10 , you must upgrade the
PBM101 module firmware to the latest version in order for the configurations produced by VersaPro 1.10  to
be usable by the module.  This upgrade is located on the VersaPro CD at the following location:
\HE693PBM101E\Version303.  Open the clickme.bat and follow the directions.

Caution

When using VersaPro Version 1.10 or earlier, you must be sure to read and comply with Product
Safety Bulletins M-04-00-03 and M-05-00-05.
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Note

When using SNP protocol, it is recommended that the communications settings be changed to the
settings described in “Serial Parameter Settings ” on page 15.

VersaPro Release 1.10 provides support for several new or updated hardware platforms including:  90-30 CPU
Release 10, 90-30 DSM314 motion module, VersaMax CPU version 1.5, VersaMax Micro, VersaMax Nano
and Series 90 Micro.  In addition, many usability improvements have been added to this release based on
customer feedback from Version 1.00.  For details on the new features, refer to “VersaPro 1.10 New Features”
(page 19) and “Problems Resolved from Version 1.0” (page 16).  Please refer to “Special Operational Notes”
(page 7) and “Open Problems” (page 17) to understand limitations with this version.

Note

In order to properly view the electronic copy of this document located on the CD, you will either need Word-
97 or Microsoft Word Viewer 97-2000.  You can obtain information on how to download a free copy of
Microsoft Word Viewer 97-2000 at the following Web site:

http://support.microsoft.com/support/kb/articles/q165/9/08.asp.

Minimum System Requirements
• 486, 66 MHz processor (except when using Profibus modules, a Pentium class processor with 32MB

RAM minimum is required)

• 16 MB RAM Memory for Windows 95/98

• 24MB RAM Memory for Windows NT 4.0

• 27 MB Hard Disk Space

• VGA Monitor

• CD ROM Drive

Operating Systems Supported
• Windows 95B

• Windows 98 (First Edition Service Pack 1, Second Edition)

• Windows NT 4.0 (Service Pack 5, Service Pack 5 international version, Service Pack 6)

Note

VersaPro 1.10 is Windows 2000 Ready:  Preliminary tests did not show any problems with Windows
2000 Beta and VersaPro will fully support Windows 2000 in the near future.  Windows 2000 requires
a minimum of 64MB of RAM.

Please note that the Logicmaster 90-30 Version 9.02 provided on the VersaPro 1.10 CD is not
Windows 2000 compliant.  For details, see the installation section under "Special Operational Notes."
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Installation
1. It is recommended that you close all applications including virus checking, Internet Explorer 5.0,and CIMPLICITY

HMI software that might be running in the background.  You may need to check the task manager to determine if
other applications are running.

2. Put the VersaPro CD in CD-ROM Drive.

3. Select the CD drive from Windows Explorer.

4. Double click Setup.exe

5. Follow the user prompts to complete the installation.  If you have a previous version of VersaPro installed, the
installation tool will first uninstall the previous version.  During this uninstall process, you may be asked whether
you would like remove shared files.  It is recommended that you always answer “No to All” to ensure that no files
are deleted that might be needed by another application.

Note

When you upgrade from VersaPro Version 1.0 to 1.1, your user screen settings and the directory
location for program files will be lost. You will need to re-establish these settings after completing the
upgrade.

Starting the VersaPro Application
The VersaPro application is installed in the GE Fanuc Software Program group.  The application can be started
by selecting Start->Programs->GE Fanuc Software->VersaPro.  It is also possible to create a shortcut to the
VersaPro application and place the shortcut on the desktop, or to click on a file created by VersaPro (the file in
the VersaPro folder with a .fld extension), and start the application in the context of the selected folder.
VersaPro may also be started using CTRL-ALT-V.

VersaPro 1.10 New Features
1. Programming and configuration for Series 90 Micro. This includes support for the following Series 90

Micro PLC models.

IC693UDR001/2 14 Point DC In/Relay Out, AC/DC

IC693UAA003 14 Point AC In/AC Out/AC

IC693UDD104 14 Point DC/DC/DC

IC693UDR005/10 28 Point DC In/Relay Out, AC/DC

IC693UAL006 23 Point Analog DC In/Relay Out

IC693UAA007 28 Point AC In/AC Out/AC

IC693UDD110/120 28 Point DC/DC/DC

IC693UEX011/012 14 Point Expansion AC-DC/DC/Relay

IC693UEX122 14 Point Expansion DC/DC/DC
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2. Programming and Configuration of the new Nano/Micro VersaMax PLCs. This includes support for
the following Nano/Micro VersaMax PLC models.

IC200NDR001 10 Point DC\DC\Relay

IC200NDD101 10 Point DC\DC\DC

IC200UDR001 14 Point AC\DC\Relay

IC200UDR002 14 Point DC\DC\Relay

IC200UAA003 14 Point AC\AC\AC

IC200UDD104 14 Point DC\DC\DC

IC200UDR005 28 Point AC\DC\Relay

IC200UAL006 23 Point AC\DC\Relay Analog

IC200UAA007 28 Point AC\AC\AC

IC200UDR010 28 Point DC\DC\Relay

IC200UDD110 28 Point DC\DC\DC

IC200UEX011 14 Point Expansion AC\DC\Relay

IC200UEX012 14 Point Expansion DC\DC\Relay

IC200UEX014 14 Point Expansion DC\DC\DC

3. Support for Series 90-30 CPU Release 10, which includes the following features:

• Series 90-30 DSM 314 Configuration. This configuration also specifies what Motion/Local Logic
Programs to download to the DSM314 via the PLC CPU.

• Configure Reboot After Fatal Fault

• Configure Serial I/O protocol

• DRUM Sequencer Function Block (same Function as VersaMax PLC).

4. Local Logic Editor for the 90-30 DSM314 that allows you to create Local Logic programs in the
VersaPro programming environment. These Local Logic Programs can be loaded from the PLC, stored
to the PLC, and verified with the PLC.

5. Motion Program Editor for the 90-30 DSM 314 that allows you to create Motion programs in the
VersaPro programming environment. These Motion Programs can be loaded from the PLC, stored to
the PLC, and verified with the PLC.

6. New Series 90-30 Module Configuration Support.

IC693PWR331 Power Supply 24 VDC 30 Watts

IC693PWR332 Power Supply 12 VDC 30 Watts

7. New VersaMax Module Configuration Support.

IC200PWR201 Power Supply 12 VDC

IC200PWR202 Power Supply 12 VDC with Expanded 3.3 VDC

IC200CPU002 CPU Module with expanded user memory
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8. Existing VersaMax Module Configuration Support listed below. These modules were configured with
Generic module configurations in VersaPro 1.00.

IC200ALG260 Analog Input Module, 12 bit Voltage/Current, 8 channels

IC200BEM103 DeviceNet Network Master/Slave Module

IC200MDL140 Discrete Input Module, 120VAC, one group of 8 points

IC200MDL141 Discrete Input Module, 240VAC, one group of 8 points

IC200MDL329 Discrete Output Module, 120VAC, isolated, 8 points

IC200MDL742 Discrete Output Module, 24VDC, positive logic, ESCP, 32 points

IC200MDD845 Mixed Input/Output Module, 24VDC In/Relay Out, isolated, 16 points in/8 points out

IC200MDD846 Mixed Input/Output Module, 120VAC In/Relay Out, isolated, 8 points in/8 points out

IC200MDD847 Mixed Input/Output Module, 240VAC In/Relay Out, isolated, 8 points in/8 points out

IC200MDD848 Mixed Input/Output Module, 120VAC In/120VAC Out, isolated, 8 points in/8 points out

9. Hardware Configuration user interface improvements:

• Reference View Restructure

• New Module Parameter Edit Feature

10. Word for Word changes for LD blocks only. PLCs that support Word-for-Word changes include Series
90-30, and VersaMax CPU.  Note: VersaMax Nano/Micro Release 1.0 and Series 90 Micro do not support
Word-for-Word changes.

11. PLC Status Dialog Additions

• OEM Protection

• CPU Password Protection

• PLC Sweep Mode/Constant Sweep Time setting

• PLC Windows mode setting

12. VersaMax PLC Version 1.5

Expansion I/O Configuration includes the following modules:

IC200ETM001 Expansion Transmitter

IC200ERM001 Expansion Receiver Isolated

IC200ERM002 Expansion Receiver

13. 'C' Block Capability for Series 90-30 High End CPUs (CPU35x, 36x)

• Import C Block from C Toolkit

• Load, Store, and Verify C Blocks

14. Auto Assign Next Highest Reference

Recalculate Highest Reference Used

15. Variable Declaration Table Programmatic Interface

16. Integrated Import of Logicmaster 90 hardware configuration and Control hardware configuration.
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17. VersaPro Release 1.10 also adds the following usability improvements:

• Reference View Table Enhancements

� Individual data formats

� Addition of Signed Decimal data formats

� Individual bit selection

� Direct editing of on-line values

� Status Bar for:  Reference Address, Binary Value and Display Font

• LD/IL Editor Enhancements

� Zoom into Blocks from LD/IL Editors

� Rung Knuckle Selection in LD Editor

� Coil justification In Configurable Columns 10-20

� Goto Coil in LD Editor

� Insert Mode for Functions in LD Editor

� Find - Instructions in Block

� Direct edit of on-line values in IL

• Variable Declaration Table (VDT) Improvements

� Variable Declaration Table Import Conflict Resolution

� Delete blank entry in VDT

� Compact variables in VDT

� Show External in VDT

� Save sort order of VDT

� Change state of all selected items in VDT

• Print Enhancements

� Implicit Cross References

� Global Highest Reference Used

• Insert of Blocks with Offsetting Capability

• On-line Cross Reference View

• Flag errors and continue on SNF Import

• Remove (filter) unsupported instructions from Function Toolbar

• Search for unused variables

• Search for Overridden Variables

• Variable View Table “array” enhancements

• Additional tabs in the Information Window – General, Cross References, and Find
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Special Operational Notes

Opening VersaPro 1.00 created folders:

When opening VersaPro 1.00 folders, the following dialog will be presented asking if you want to recheck the
folder.  The purpose of the re-check is to flag any syntax errors that were not being caught by 1.00 version (see
Changes in Syntax Check topic discussed later in the Special Operational Notes section).  It is recommended
that you select Yes, perform a check all on the folder and correct any syntax errors.  After going through this
process, the message will not be presented the next time the folder is opened.  Selecting No, will not force you
to recheck the folder or correct any syntax errors.  However, the dialog shown below will appear each time the
folder is opened.

Changes in Syntax Check

1. VersaPro 1.10 has additional syntax checks to catch errors that were not detected in the previous version.
This means that programs that previously compiled in VersaPro 1.00 without errors may have errors when
using VersaPro 1.10.  If this occurs, you can double click on the error message in the Information Window
to navigate to the error.  For example the following rung would compile in VersaPro 1.00 without error:

However, this type of construct should not have been allowed because power flow around a function block is
not allowed in the 90-30 and VersaMax PLCs.  This type of construct should be converted to the following
structure to achieve the same functionality:
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2. In some cases VersaPro 1.00 allowed the Boolean output of a function to be used as a power flow input to
another function.  This is considered an illegal construct which is now being flagged as an error in
VersaPro 1.10.  An example is shown below:

Note

The above syntax checks will not become effective for folders produced with earlier versions of
VersaPro unless you make a change and recompile on a per block basis.  The syntax checks will be
immediately effective on new folders and new blocks.

3. Another new check prevents the use of negative decimal constants as parameters with a function like
RANGE_WORD. The reason is that this function treats all parameters as unsigned decimal.  For example,
if a range from -1000 to + 1000 is programmed, the results will be the opposite of what you might expect
because  –1000 will  be executed as an unsigned positive number, +64536..  If you want to use negative
parameters, you should use the RANGE_INT function.  This same check is also applied to other functions
that require or allow Word constants (for example MOVE_WORD).

IL Issues:

• Due to LD to IL conversion issues, the LD to IL conversion has been turned off in this version.  This functionality
will be corrected and turned back on in the next release.  IL to LD conversion is still supported.

Series 90 Micro Issues

1. There are few cases where you will not be able to establish Logic Equality with the Series 90 Micro PLC after
storing or loading.  These issues relate to the fact that the Series 90 Micro calculates its own highest reference
used rather than using the value provided by VersaPro.  You should also perform a “Check All” before storing
the program to ensure equality.  There are similar problems in Logicmaster for the DOIO and Move_bool
instruction.  (CR71458, CR71694, CR72644).

a. Adding a %S7 Always On (ALW_ON) contact for some programs may be required in order to gain
equality.  This occurs if the program uses function blocks connected directly to the power rail (i.e. without
an interposing contact).  Since the Series 90 Micro does not allow function blocks to be directly connected
to the power rail, VersaPro inserts a hidden %S7 contact.  If the program does not use a %S7 contact
explicitly in the program, the Series 90 Micro will not use the %S7 in the highest used reference
calculation.  However, VersaPro does use the %S7 in the highest used reference calculation.  The Series
90 Micro also requires the programmer to  insert a hidden ALW_ON contact after a timer function which
can also cause the same issue.
Resolution:  In these cases, you should add a %S7 contact somewhere in the program.  This will allow the
program to be stored and the status will show Logic Equal.
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b. If you use a MOVE_BOOL instruction that has an output operand with the same address as the ALT
input operand on the DO_IO instruction, VersaPro will not go equal after a store to the Series 90 Micro.
The problem is that the use map is calculated differently between VersaPro and the Series 90 Micro in this
case. This same issue also occurs in Logicmaster.

Resolution:  The simplest way to fix this is to not use the same address on the output of a MOVE_BOOL
and the input of the DO_IO.  If this is not possible, you can add a MOVE_WORD with the output operand
set to the same address used by the MOVE_BOOL and DO_IO Alt input.  This causes the use maps to be
calculated the same in VersaPro and Logicmaster.

c. Using temporary variables can cause an equality issue with the Series 90 Micro. Create a Series90
Micro folder and connect to the PLC. Declare temporary variables: for the Boolean temporary variables
use %Q or %M.  Store to the PLC. The store will be successful; however, “Logic Not Equal” will be
displayed.  Perform a verify of Logic and the _Main.dec file will be not equal.  This is due to the
recalculation of the Dec file by the Series90 Micro PLC. (CR72430)

Resolution:  Use %T as the temporary Boolean memory area and the folder will be equal after storing to
the Series 90 Micro.

2. The IL language is not supported on the Series 90 Micro.

3. Invalid Program after import and modification of Series 90 Micro LM90 folder.  A Logicmaster 90 Micro
program that contains a vertical wire immediately in front of a single coil will result in the error 0x05F2 -
Invalid Program (or too large for PLC) if it is imported into VersaPro, edited, and then stored to the Series 90
Micro PLC. For details, see CR73144 on page 24.

Conversion of Series 90 Micro Folders to VersaMax Nano/Micro folders:

Use the following steps to convert Series 90 Micro folders to VersaMax Nano/Micro folders:

a. Select File -> New Folder;  provide a folder name for the new VersaMax Nano/Micro folder, a location for the
folder and a description if desired.

b. Press the Next button

c. Choose “Import Logicmaster 90” radio button and select the Logicmaster Series 90 Micro folder under the
“From:” text box.

d. Press the Finish button;  VersaPro will convert the Series 90 Micro folder to a VersaPro folder

e. Open Hardware configuration from the toolbar button, from the View menu or by entering Alt + 4 to change
the hardware to a VersaMax Nano/Micro configuration.

f. Under the Hardware configuration application, select File -> Convert to -> VersaMax Nano/Micro.  Select Yes
to the “Convert to VersaMax Nano/Micro Rack System” dialog.  This creates a UDR005/010 configuration.  If
this is not the type of VersaMax Nano/Micro required, right mouse click on the picture of the module, select
“Replace CPU” and select the desired model from the list.

g. Select Yes to the HWC dialogs.

h. Return to the main VersaPro application;  select Tools-> Non-Nested to Nested Conversion; Select Yes to the
VersaPro dialog.  This will convert any non-Nested Jumps and Labels used by the Series 90 Micro program to
the Nested form of the instructions supported by the VersaMax Nano/Micro.  This conversion will increase the
size of the program slightly.

i. The Hardware configuration for the VersaMax Nano/Micro will be the default configuration since the
hardware configuration conversion process does not copy the specific Series 90 Micro configuration.  You
should set the VersaMax Nano/Micro configuration parameters to match those in the Series 90 Micro
Logicmaster folder.
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j. This completes the conversion process.

Ethernet Global Data (EGD) Issues:

1. EGD configuration Compatibility Issue:  VersaPro does not allow you to configure EGD exchanges for one byte
of data (or an odd number of bytes) when using word type memory such as %R, %AI or %AQ.  These exchanges
are always even byte exchanges (2, 4, …).

Resolution:  To send or receive one byte (or an odd number of bytes) of data via EGD to PLCs programmed
with Control or other non GE Fanuc PLCs, VersaPro must configure the EGD bytes in bit type memory
(%I,%Q, etc).  Word memory (%R etc) does not allow addressing in individual bytes which means a word
causes 2 bytes to be used in EGD transactions. (CR72716)

2. The configuration for Ethernet Global Data can not be loaded from the PLC.  Uploading a hardware
configuration from a PLC containing EGD will result in loss of EGD configuration in the folder (though it will still
exist in the PLC). (CR69711).

Resolution: The load dialog provides a warning that data will be overwritten.  Always make sure that you have a
back-up before you load a hardware configuration from the PLC.  This is a good programming practice in any
situation.

Installation Issues
1. After installing VersaPro 1.10 and then subsequently installing VersaPro 1.00, 1.01 or 1.02, you may receive

the following error during the installation process:

In addition, you may not be able to connect to PLCs after the installation completes and the following error
message may appear.

Resolution:  A VersaPro 1.10 user wishing to install VersaPro 1.0 can avoid this problem by following these steps:

a. Uninstall VersaPro 1.10:  In the Windows Start menu, select Programs\GE Fanuc
Software\VersaPro\Uninstall.  You can also open the Control Panel's Add/Remove Programs, then select
"VersaPro 1.10" for removal.  (Uninstalling VersaPro 1.10 by letting the VersaPro 1.0 installer perform
the uninstall should be avoided.)

b.  After the uninstall, shutdown and restart the computer.
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c. After the computer has started up, delete the "\Program Files\Common Files\GE Fanuc
Automation\PLCServer" directory on the hard drive that contains the computers operating system.  If you
don’t delete this directory and instead choose to delete all the files in the directory, you should make sure
that the “Show All Files”  option is selected under Folder options in Windows explorer.  This is to ensure
that all files including hidden files are deleted from the directory.

d. Install VersaPro 1.0.

2. VersaPro 1.10 beta customers who previously used builds 1122 and 1129 may see the following error when
opening VersaPro for the first time: "gfx_enu.dll is missing".  The problem is due to a issue in the beta
versions.

Resolution:  Re-installing VersaPro 1.10 a second time will resolve the issue.

3. Logicmaster 90-30 Version 9.02 provided on the VersaPro 1.10 CD is not Windows 2000 compliant.  When
installing Logicmaster 90-30 Version 9.02 with the Windows 2000 operating system, you will get the following
error:

Even though this message occurs, Logicmaster appears to work correctly, but it cannot be guaranteed.

Resolution:  Logicmaster should be installed on a PC that supports the Windows 95, Windows 98 or Windows NT
operating system.

4. During the installation process, you may be asked to re-boot the PC.  In some instances you may receive the
following messages on the Windows NT 4.0 operating system:  “Your hard drive may be corrupt.  Autochk is
running.  Skipping Autochk may make the volume unmountable.”   Autochk will complete, NT comes up as
expected, VersaPro operates normally and there are not errors on subsequent re-boots.

Resolution:  The problem is caused by starting the re-boot process before a Crypkey service completes and this
makes the system believe there was a problem on the previous shutdown.  This causes no problems for the system
and VersaPro installs correctly.

5. When installing on Windows 95/98, you may receive the following error:  “Isuninst has performed an illegal
operation and will be shutdown.”.

Resolution:  You should simply close the dialog and the install will proceed normally and VersaPro will be
installed correctly.

6. When installing on Windows 95/98 and selecting “Yes” to re-boot the PC to complete the installation, the PC
may lock-up rather than power down correctly.

Resolution:  You can reset or power cycle the PC.  The PC may run scan disk on power-up but will power up
correctly and VersaPro will install normally.
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7. VersaPro loses default CCU settings if HMI project exists. VersaPro loses all the default CCU settings if HMI
has been installed prior to it and an HMI project has already been created. The gef_cfg.ini file created by HMI does
not put information about the serial devices used in the project.

Resolution:  Using a text editor, such as Notepad, open the file gef_cfg.snp and copy and paste its contents into
gef_cfg.ini. Edit gef_cfg.ini to provide the correct defaults.

Memory Leak when On-line using Windows 95/98

1. For users with Windows 95, a memory leak exists in the communications sub-system due to an
unresolved issue in Microsoft’s DCOM.  This will cause the memory usage to grow when you are on-line
and actively monitoring changing values on the PLC (~150 bytes per change in data that is in view).  There
will also be some memory growth even when monitor is off due to updating the PLC status.  Depending on the
amount of data that is changing, this can cause the program to start running very slowly or become totally
unresponsive after approximately  12 hours of continuous usage (CR72361).  In addition, this problem can also
prevent VersaPro from reconnecting with the PLC after first being on-line and then disconnecting.  This
problem occurs because the communications server may not have completed the disconnect process due to the
time needed to recovery memory.

Resolution:  You should disconnect when not actively viewing on-line PLC values.  In addition, you should
select Monitor Active rather than Monitor All when viewing on-line values when possible.  If constant
monitoring is required, it is recommended that you re-boot the PC once a day to recover the lost memory or use
the NT operating system.  If you cannot reconnect after a disconnect, you should re-boot the PC.
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Profibus Issues:

Caution

When using the 90-30 Profibus Master Module (HE693PBM101) with VersaPro 1.10 , you must upgrade the
PBM101 module firmware to the latest version in order for the configurations produced by VersaPro 1.10  to
be usable by the module.  This upgrade is located on the VersaPro CD at the following location:
\HE693PBM101E\Version303.  Open the clickme.bat and follow the directions.

1. If VersaPro is run on a 486 66Mhz PC with 16MB RAM on the Windows NT operating system, the response
when adding a 90-30 Profibus module HE693PBM101 can be slow (up to 60 seconds before the Parameters
Dialog for the Module appears).  This is caused by some changes to improve the user interface in the hardware
configuration and because the Profibus module configuration size has increased significantly. (CR71380)

Resolution:  When using Profibus modules in the configuration, you should use a PC with a Pentium class
processor and 32MB of RAM minimum.

2. When loading a Profibus module HE693PBM101 with an older configuration, the configuration will be
automatically converted to a new format required to support the new capabilities of the module.  However,
this means that the configuration is not compatible with the older module.  At this point you must upgrade the
firmware of the Profibus module in order for the new configuration to be usable by the module.  This upgrade is
located on the VersaPro CD at the following location: \HE693PBM101E\Version303.  Open the clickme.bat and
follow the directions.

Resolution:  The Profibus module firmware should be updated at the same time that the VersaPro 1.10 is installed
to avoid this issue.

Docking/Undocking Issues

1. If the information window, folder browser window or variable declaration table (variable table) window
are undocked and you click in the undocked window, you will not be able to select any items from the
main menus or other windows in VersaPro until the window is docked again.  These windows can be
docked and undocked by using the right mouse within the window and selecting the “Allow Docking” item.

Resolution:  You should undock these windows only temporarily in order to move them to a new docked
location.

Word for Word Issues:

• Word for Word online edits cannot be performed on output coils when the "Coil justification column" option is
set under the menu "Tools -> Options", "Ladder" Tab.  Word for Word specifications indicate that  COIL ( ),
CLOSED_COIL (/), SET (S), RESET (R), TRP(↑), and TRN (↓) should all interchange.  When these exchanges
are attempted, the coil justification option kicks in and makes the replacement a new coil, making the status go
NOT EQUAL. (CR71286)

Resolution: The coil justification column should be turned off when doing word for word changes on these
outputs.
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Known Crashes or Lock Up

1. Insert row in VDT local tab with all blocks closed causes endless loop.

Details: Close all blocks. Switch to the local tab in the variable declaration table (VDT). Select "insert row".
This puts the program in an endless loop and VersaPro must be closed with the Task Manager. After closing,
you are prompted to save the VDT. On re-opening the folder a variable with no name exists. (CR72739)

Resolution:   You should not attempt to insert row on the local tab in the VDT when all blocks are closed.

2. Attempting drag on undocked window outside of the VersaPro application window may cause a crash.
(CR72655)

Resolution:   You should not attempt to drag an undocked window outside of the VersaPro frame.

3. VersaPro crashes when putting focus on Find/Replace dialog after closing folder (CR73125)

Details:  Start VersaPro and create a new or open an existing folder.  Select Edit->Find/Replace which brings
up the Find/Replace dialog box.  From VersaPro, select File->Close and then click on any part of the
Find/Replace dialog box.  VersaPro crashes with the following Application error message:  “The instruction at
‘0x5f40277e’ referenced memory at ‘0x00000000’.  The memory could not be ‘read’.”

Resolution:  To avoid this problem, you should not close the folder after starting the search and replace
process.

4. VersaPro locks up during a search operation if focus is placed 5 rows below the last row of logic in a
block with 6 rows or less of logic.  (CR72963).

Resolution:  Before performing a search on a block that has 6 rows or less of logic, you should place focus on
a cell that contains logic.

Communications Issues
1. VersaPro Stops Communicating with CPU352 on the PLC’s second serial port on Windows 95/98

(CR73211).

Details: VersaPro will run for about 20-30 minutes communicating with a CPU352 on the second serial port.  After
that the light on the PLC stops flickering, indicating the CPU is no longer communicating with the programmer.  If
you disconnect and then  reconnect, you will get an error 'Entry not found in Database' Major Code = 0”.

Resolution:  When using VersaPro with Windows 95/98 to communicate with a CPU352, it is required that you
communicate with the PLC through the serial port on the power supply.  In order to release the communications
driver for correct operation if you do encounter the problem, you must perform a Ctrl-Alt-Del and then terminate
the gefsrv.exe and hdrvsnp.exe programs.

2. Many communication issues can be resolved by properly setting the communications timing parameters which
may have been altered from previous programmer sessions on the same PC.  Here are some guidelines which
can sometimes help when experiencing communication problems:

Guidelines for Communications Configuration

The Communications Configuration Utility (CCU) allows you to view and change your settings for the PLCs
that you connect to (over Ethernet or serial line). This information is intended to give you guidelines on how to
configure your communications parameters properly.



Important Product Information 15

GFK-1671E

Invoking the CCU

From VersaPro you can select Tools -> Communications Setup to invoke the CCU application.

From a command line (within a MS-DOS box or from Start -> Run) you may enter GEFCCU32.EXE. This
application is installed in the Windows root directory (usually C:\Windows for Windows 95 or Windows 98,
and usually C:\WinNT for Windows NT). Since this location is always in your path, you do not need to
specify the path when invoking the CCU.

Logging In to CCU

When you first invoke the CCU, you are presented with a dialog box asking for a password. If you only want
to look at your communications parameters (not making changes), then you may click the "View Only" button
to view the parameters in Read-Only mode.

The default password is netutil  (all lower case). This password can be changed (by the Change Password
button on the Password dialog box).

Serial Parameter Settings

The original COM port settings that were distributed with Control version 1.00 (and Beta versions earlier than
that) had invalid settings for some of the SNP timers (SNP is the GE Fanuc proprietary protocol used to
communicate to PLCs over a serial line). These settings can be inherited by VersaPro since it uses the same
communications driver.  If you encounter communications difficulties, it is recommended that you  check your
settings in the CCU on the Port tab for each serial COM port and use the following values:

1. Select the Display Advanced Parameters checkbox

2. If you need to make changes, click the Edit button.

3. Set your Request Timeout to 20000 or higher (units are in milliseconds, highest valid value is 63000).

4. Set your SNP_T3 parameter to a value at least 250 greater than Request Timeout. For example, if your
Request Timeout parameter is 20000, set SNP_T3 to 20250 or more.

5. Set your SNP_T3P parameter to a value at least 250 greater than your SNP_T3 parameter. For example, if
your SNP_T3 parameter is 20250, set your SNP_T3P parameter to 20500 or more.

6. Set your SNP_T3PP parameter to a value at least 250 greater than your SNP_T3P parameter. For example,
if your SNP_T3P parameter is 20500, set your SNP_T3PP parameter to 20750 or more.

7. You will need to click OK on both the Edit dialog box and on the main CCU screen to save your changes.

Modem Issues
1. When editing modem parameters in the CCU, any settings made in the setup that the Configure Line button

brings up are not saved.

Resolution:  In order for the modem settings to be retained, they need to be entered through the Windows
operating system.  From the Windows Start menu, select Settings->Control Panel->Modems.

2. When setting up VersaPro to communicate with the PLC via modem, the user should ensure that the settings in
the PLC match those of the modem.  For example, for typical modem applications the PLC should be set up for
19200 baud, no parity, 1 stop bit, and a modem turn around time of 1 using the hardware configuration
package in VersaPro and then storing this configuration to the PLC.
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Next, the programmer's PC port must be set up through the Windows operating system by selecting Start->
Setting->Control Panel and selecting the Modems icon.  The Modems Properties dialog box will appear. The
Modem Properties should be set to match the PLCs configuration for number of bits, parity and stop bits.  The
Advanced Connection Settings should be set to enable Use Flow Control and Hardware (RTS/CTS).

3. From VersaPro, the user should select Tools -> Communications Setup to invoke the CCU application.
Select Ports->Edit to set the modem turn around time.

Reference View Table Conversion

Upon opening a VersaPro 1.00 folder, the Reference View Tables will be converted to the new format.
However, the table formats will be reset to the defaults.

Problems Resolved From Version 1.0
1. When a variable is created with a length greater than can be displayed in a window in the Variable

View Table it is not possible to scroll to see all values for that variable in the table.  The scroll bar is
not available to scroll within the context of a single variable. (CR68624)

Resolution: The scroll bar is now available.

2. It is not possible to paste a rung after the last rung in a ladder logic program.  It automatically gets
inserted immediately prior to the last rung of the program. (CR69569)

Resolution:  The rung now gets inserted into the proper location.

3. It is not possible to change the display format of individual entries in the Reference View Table.

Resolution: Reference view table now support this functionality.

4. It is not possible to display double integers (DINT) as a display format in the Variable View Table.
(CR69712)

Resolution:  DINT is now supported in VVT.

5. While monitoring Logic and References, the animation of data may appear to slow down after
extended periods of operation. (CR70024)

Resolution: corrected in this version.

6. An application error may occur when attempting to print to a printer that is not connected to the
PC. (CR70057)

Resolution: corrected in this version.

7. If the PC is not connected to an Ethernet LAN, and you attempt to connect VersaPro via Ethernet,
VersaPro may stay in the Connecting condition. (CR70076)

Resolution: corrected in this version.

8. On some Windows 95 or Windows 98 computers, the VersaPro application does not terminate
properly if a user initiates a Windows Logoff while VersaPro is still running.  Once this occurs, you
must reboot the computer in order to re-start VersaPro.  (CR69710)

Resolution: corrected in this version.
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9. The default display format for timer and counter variables in the monitor mode is a hexadecimal
display. Many users prefer to see the decimal equivalent of these values at run time. (CR69346)

Resolution: The default format for timers and counters is decimal in this version.

10. If CIMPLICITY HMI is running during installation including running in the background,
VersaPro will not be properly installed and the HMI application will no longer run properly.
(CR71683)

Resolution:  VersaPro will now install correctly even if HMI is running.

11. The process for creating a variable can not be aborted or cancelled.  Once an entry in the Variable
Declaration Table is initiated, it must be completed before it can be deleted.  (CR68086)

Resolution: corrected in this version.

12. When using the IL editor to paste text data to a text editor application such as Microsoft NotePad,
Multi-line comments lose internal formatting characters (carriage returns and line feeds).  This
compresses the comment into a single line.

Resolution: corrected in this version.

13. If multiple variables at the same scope reference the same reference address within the PLC, a
conflict message will occur to prevent you from storing reference values to the PLC.  This restriction
is limited to within VersaPro, and in no way does this restrict an HMI package from accessing this data.

Resolution: corrected in this version.

14. It is not possible to double-click on a call instruction in logic and automatically open that block for
editing.

Resolution:  This was resolved by the new right mouse menu option to Open block.

Open Issues and Problems

Open issues from Version 1.0:

1. If you load a hardware configuration from the PLC with the Hardware configuration window open,
that hardware configuration is not automatically saved.  If you close the folder at this point without
saving the configuration, the loaded hardware configuration will be lost.

Suggested Resolution: There are two simple remedies to this situation: Save the hardware configuration
immediately after it has been loaded, or make sure that the hardware configuration application is closed
whenever you load a hardware configuration from the PLC. (CR69799)

2. Auto-configuration of VersaMax generic modules is not supported by hardware configuration.  If
you upload a configuration from an auto-configured VersaMax PLC, all generic modules will be replaced
by an empty slot. (CR69308)

Suggested Resolution: There is no requirement that you load the Hardware Configuration if the system is
autoconfigured.  If you choose to load the hardware configuration for documentation purposes,  you will
need to configure generic modules after loading the hardware configuration from the PLC in this situation.

3. Coil use checking only checks for explicitly used coils.  If you write to outputs (%Q memory) with a
word-oriented function, only the first bit of this memory type will be checked during the coil check
process. (CR69797)



Important Product Information 18

GFK-1671E

Suggested Resolution:  The find operation has implicit reference capabilities to check for this type of
operation.

4. Cut and paste of parameters does not work as expected.  When an input parameter from a function
block is copied, it can not be placed as an output parameter on a function block. (CR69512)

Suggested Resolution:  Parameters are instance-specific.  Inputs to function blocks can be copied to
inputs on other function blocks – they will not attach to outputs.

5. It is possible to configure the VersaMax Thermocouple Module (IC200ALG630) with parameters
that exceed the modules range.  If this happens, you will be presented with a System Configuration
Mismatch Error in the PLC Fault Table.  Until this fault is corrected, this module will not function in the
PLC system

Suggested Resolution: Clear the PLC Fault Table, Re-configure the module using the correct parameters
for the attached thermocouple device, and store the configuration to the PLC.

6. The VersaPro product uses the latest version of GE Fanuc communication services.  Products that use
TCP communications drivers that are common with VersaPro must be installed before VersaPro in order
for VersaPro to operate properly with Ethernet network. This is a TCP I/P driver registration issue. This
includes such products as Host Communications Toolkit and Control. If version 2.2 or later of Control is
used on the same PC as VersaPro, this is not an issue.

Suggested Resolution: Install VersaPro last, or re-install VersaPro to correct the driver registration.

7. Storing a hardware configuration that does not match the physical hardware in the rack does not
generate fault message in VersaPro and VersaPro states that the item Stored Normally. (CR69473)

Suggested Resolution:  The PLC provides a Config Mismatch fault which can be observed in the Fault
Table.
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Other Open Issues:

Communications Issues

ID Description

CR72181 Communications server (gefsvr) is not unloaded when VersaPro is closed.
Details: When closing VersaPro, one of its components that handles communications with the
PLCs will remain in memory (gefsvr). When VersaPro is started again, it uses the existing
gefsvr component rather than creating a new server.  There are no detrimental side effects of
leaving this component in memory except that users of laptop computers may have an issue
with shutting down..

Resolution:  If you use a laptop computer with Windows NT, the gefsvr component can be
shut down through the task manager. If you use Windows 95 or 98, shut down gefsvr by
pressing Ctrl-Alt-Del one time, selecting gefsvr from the list of  tasks and then selecting the
End Task button.

CR72971 VersaPro Can Not Reinitiate Communications After repeated load/stores/disconnects.
Details: In the course of running a test which load/stores/connects and disconnects from the
PLC many time, VersaPro will not reconnect.  The connection attempt does not time out, it
just keeps trying.  The connection attempt can be aborted but any subsequent connection
attempts will not be successful

Resolution:  The user can end the following communication tasks through the Task manager
(Windows NT) or through Ctrl-Alt-Del (Windows 95/98):  gefsrv.exe and hdsrvsnp.exe.  This
will allow connection to the PLC again.  The other option is to re-boot the PC.

Association of Device Feature in CCU Not Used by VersaPro
Details: The CCU is a shared software component with the Control programmer.  This utility
includes a feature called Association of device which is used by Control.  This feature is not
supported in VersaPro.

Resolution:  The Association of Device feature in the CCU should not be used in conjunction
with VersaPro.

DSM314 Local Logic and Motion Program Issues

ID Description

CR70864 Motion and Local Logic Editors Displaying Unprintable characters under Windows 95.
Details: Create a comment text below using Microsoft-Word as an editor (Times New Roman,
font size 10).  When text is copied into local logic and motion editors, the four dots were
replaced with the unprintable square box and one dot.  This occurs only when running under
Windows 95.  It is not a problem on Windows NT.

//This is a simple comment that
//can be copied into an editor....

Resolution:  When using Word as a text source for motion programs, you should configure
Word to view only printable characters.  This can be selected under Tools->Options->View.
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ID Description

Incorrect Time Constant descriptions and unsupported variables in Local Logic
Variable Table
Details:
1) The comments for Position_Loop_TC_1 and Position_Loop_TC_2 are incorrect. The
comment reads "Position Loop Time Constant command in units of 0.01 ms" which is
incorrect. It should read "Position Loop Time Constant command in units of 0.1 ms".
2) Servo_Ready_3 variable is not supported.  The motion parser will issue an error message if
this variable is used in a local logic program.

Resolution:  The user should take into account that the time constant for Position Loop Time
is in 0.1ms rather than 0.01ms.  Also, the Servo_Ready_3 variable should not be used.

Find and Replace Issues

ID Description

CR72914 Find/Replace Auto-Assign Increments by 16 on contacts/coils.
Details: Using the Find/Replace dialog, I specified to replace %S00008 with %T. Each time
the replace occurred on a contact, the Auto-Assign created a new Word type variable. You
would expect it to create a new Bit type variable since a Bit type memory is specified for the
replace.  This issue also applies to IL Blocks and Boolean Constructs (I.e. LD_BOOL,
ST_BOOL,...)

Resolution:  You should avoid using the auto-assign feature when using find/replace since the
assignments will not be optimal and the type created for the replacement may not be correct.
To avoid using the auto-assign feature, you must specifically put a reference address in for the
replace.  For example %T2 in the case described.

Hardware Configuration Issues:

ID Description

CR71631 Incompatibility between MS IntelliPoint Mouse S/W and VersaPro H/W Config.
Details: The IntelliPoint software enables you to expand Mouse properties.  Under the
Visibility Tab, one of the parameters is Hide Pointer While Typing.  If this parameter is
selected and you attempt to edit CPU or module parameters, the mouse pointer disappears.

Resolution: The mouse pointer re-appears once the pointer is positioned outside the H/W
Config window.  If another application is selected to be in focus and then the H/W Config
window is re-selected, the pointer re-appears.   Another work around is to disable the "hide
mouse pointer while typing" feature in the IntelliPoint software.

CR72897 HE693PBM101 - Import of GSD with comments on Module/EndModule fails.
Details When configuring the HE693PBM101 Profibus Master module, importing some GSD
Files from the Slave Information tab may fail.  GSD files that have comments inside the
Module/EndModule declaration cannot be imported in this release.

Resolution: With any text editor, remove the comments from the GSD file and try again.
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ID Description

CR72919 Windows 2000 - Opening Hardware Configuration without Administrator privileges
gives error.
Details:  If you log on to Windows 2000 and do not have Administrator privileges to Windows
2000, then every time that you open Hardware Configuration you get the message:  "Failed to
update the system registry.  Please try using REGEDIT."  Click OK to this box and HWC
opens normally and there don't seem to be any problems with it.
Resolution:   Hardware configuration opens and operates normally despite the error message.
To avoid receiving the error message, you can log on as Administrator of the PC.

CR71294 Windows NT - When you press F1 in the Data Entry Tool, a "help topic does not exist"
message appears.
Resolution:  Press the dialog box Help button.

CR72999 After load of old Profibus master configuration (PBM101) , verify after successful store
of HWC reports checksum and Rack&IO NOT EQUAL
Details:  When loading from a PLC that contains the configuration for an older Profibus
module, the configuration is converted to the new format.  However, the hardware checksum
is not recalculated which prevents the hardware configuration from being equal with the PLC
after a store.

Resolution:  The user should make a small change in a hardware configuration item which
will force the hardware configuration to re-calculate its checksum.

CR73008 If a "module" list in a GSD file contains more than 320 bytes, Hardware Configuration
crashes.
Details: Importing a GSD file which contains a "module" list that exceeds 320 bytes causes
Hardware Configuration to crash.

Resolution:  The module list in the GSD file must be shortened to 320 characters.  To make
maximum use of the size available, spaces should be eliminated.  If the module list required is
still greater than 320 characters, shorten the module list to 320 characters, import the GSD file
and then enter the rest of the information directly through the hardware configuration utility in
VersaPro.

CR73061 EGD Configuration erroneously appears to be stored successfully to the CPU364
Revision 9.01, which does not support EGD.
Details:
1) Create an EGD Producer Exchange in VersaPro, Hardware Configuration CPU364
2) Connect to a 364 Firmware Version 9.01.  The store will succeed with no errors reported to
the user.
3) Set the PLC to Run and try to read the exchange data. No EGD exchanges happen because
this version of firmware does not support EGD.  However, VersaPro should inform the user
that the feature is not supported on the store.

Resolution:  You should upgrade the CPU364 to firmware revision  9.10 or later when
configuring a CPU364 for EGD exchanges.
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HMI Interaction Issues

ID Description

CR71605/
CR71607

DCOM for Windows 95 version conflict between VersaPro and CIMPLICITY HMI
Details: There is a version conflict of DCOM for Windows 95 between VersaPro and
CIMPLICITY HMI (version 4.01).

STEPS T0  REPRODUCE
1) Install VersaPro.
2) Install HMI.
3) During the beginning of the installation of HMI, a dialog box is displayed with the message
"A newer version of DCOM for Windows 95 had been installed. To override, you must
uninstall the current version first."  The dialog provides only one OK button.
After pressing the "OK" button, the installation proceeds normally and the install is not
aborted even though the message suggests that it should abort.
4) Authorize VersaPro.
5) Authorize HMI.
6) Run the VersaPro program and set the PLC to run mode so that a variable can be imported
into HMI and that the values are read from the PLC and updated on the HMI screen.
7) Run an HMI project that monitors the point in the PLC and observe the variable online
value updates in the point control panel.
8) Stop the HMI project from the HMI workbench.
9) On stopping the project an illegal operation dialog comes up with the message:
"HCT_rp caused an invalid page fault in module MFC42.dll at 0137:5f4012a1"

Resolution:  Even though this error is produced, the HMI project stops without any problems.
The HMI project can also be re-started without any issues.

Information Window Issues:

ID Description

CR71367 Information Window Scroll Bar Issue.
Details: In the Information window the following incorrect characteristic exists.

When an information window is resized to a larger window, the slider bar/button in the slider
area on the right hand side of the display grows to the point it cannot be not be moved up and
down.  It, therefore, cannot be used to scroll the window (and there is information that can't be
seen on the screen).   The arrow buttons are the only method to scroll the window.

Resolution:  The window can be re-sized or the arrow keys can be used to see the information
not in view.
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IL Issues:

ID Description

Previously created Folders with IL give error.
Details:

The following IL logic in VersaPro 1.00 stored with no errors to the PLC.

SHFR_BIT(

     R := %T00210 %T00210

     IN := 0

     ST :=%R00778 %R00778

     Length := 5

     Q => %Q00178 %Q00178

)

SHFR_WORD(

     R := %T00210 %T00210

     IN := 43981

     ST :=%R01036 %R01036

     Length := 5

     Q => %Q00193 %Q00193

)

Storing this same logic to the PLC using VersaPro 1.10 fails with two errors: ERROR:
[SHFR_BIT(] The accumulator stack is empty.

ERROR: [SHFR_WORD(] The accumulator stack is empty.

IL - 2 error(s), 0 warning(s).

However, VersaPro 1.00 should have flagged this program as an error because these function
blocks require the accumulator be initialized with a LD_BOOL instruction in front of them.
VersaPro 1.10 has corrected this and will give the errors shown for the sample program above:

You may find existing folders that previously compiled with no errors will now have syntax
errors.

Resolution:  You should correct your folders by adding a LD_Bool in front of the following
functions:  SHFR_BIT and SHFR_WORD.

The following functions also require the LD_Bool function in front of them in order to pass
syntax check.  However, VersaPro 1.00 was already checking these functions and so existing
VersaPro 1.00 folders should not have syntax errors on these function blocks.

CR72862

TMR_TENTHS
TMR_HUNDS
TMR_THOUS
OFDT_TENTHS
OFDT_HUNDS
OFDT_THOUS
ONDTR_TENTHS

ONDTR_HUNDS
ONDTR_THOUS
BIT_SEQ
PID_ISA
PID_IND
SER
DRUM
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Import of LM90 or Control Folder Issues

ID Description

CR71941/
CR71940/
CR71976

Control Version 2.20 VersaMax Configurations can't be imported into VersaPro.
Details: Control Version 2.20 VersaMax folders can't be imported into VersaPro.

Resolution:  Control VersaMax folders should first be opened with Control Release 2.3  and
then saved.  The updated folder can then be imported into VersaPro.

CR73144 Invalid Program after import and modification of Series 90 Micro LM90 folder.
Details:  A Logicmaster 90 Micro program that contains a vertical wire immediately in front
of a single coil will result in the error 0x05F2 - Invalid Program (or too large for PLC) if it is
imported into VersaPro, edited, and then stored to the Series 90 Micro PLC. The Series 90
Micro does not support the optimization that VersaPro performs on this structure.

Example:

Resolution:  The work around is to add an ALW_ON contact in front of any single coil that
has a vertical wire immediately in front of it.

Example: An ALW_ON contact was inserted in front of the M2-FWD coil.
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Installation/Licensing Issues:

ID Description

CR71676/
CR71599

Installation of CIMPLICITY HMI 4.01 after VersaPro causes General Protection Fault.
Details:  After installing CIMPLICITY HMI 4.01 with VersaPro already installed and using
VersaPro with a 9030 PLC, a message box popped up with the message "This program
performed an illegal operation and will be shutdown.  Details:   VersaPro caused a general
protection fault in module CRP9516A.dll at 0001:0000bd72." After this error is encountered,
you won't be able to launch the VersaPro application.

Resolution:   The HMI install is overwriting a newer version CRYP95A.DLL file which is
needed by VersaPro.  The solution to this problem is to re-install VersaPro.  This will re-install
the correct file and HMI will continue to run correctly.

CR72511 Convert File system from FAT to NTFS and defrag of disk remove VersaPro license.
Details:

1.  Install and License VersaPro

2.  Open Control Prompt

3.  Type at the Prompt convert c: /fs:ntfs
4.  In response to the prompt "Do you want to convert at start up?" type y for "yes."

5.  Restart your PC.

6.  Observe conversion during OS Loader7. Log on and run VersaPro and message indicates
that VersaPro needs to be licensed.

This is also occurs after defrag of the disk.

Resolution:  You should not change the file format or defrag the disk where VersaPro is
installed.  If this is needed, VersaPro will need to be re-licensed on the affected PC by
selecting the Register Now item in the VersaPro program group.

CR73074 Settings.reg error on VersaPro 1.10 install after manually deleting files
Details:

Steps to reproduce:

1) Install VersaPro 1.0.

2) Manually delete the files from "\Program Files\Common Files\GE Fanuc
Automation\PLCServer" and the files from "\Program Files\GE Fanuc Automation\VersaPro"

3) Install VersaPro 1.10 from the CD

4) Upon Installation the following error was received:  "Cannot import settings.reg: Error
opening the file.  There may be a disk or a file system error.

 After dismissing this error, install continues but it also appears that the license tag on the
subsequent dialog is missing.

Resolution:  You should not delete files in order to perform an uninstall of VersaPro.  In order
to correct the problem after deleting the files and receiving this error, you should re-install
VersaPro and it will install correctly.



Important Product Information 26

GFK-1671E

ID Description

CR73105 VersaPro 1.0 uninstall issue
Details:

-Clean machine

-Install VersaPro 1.0 Service Pack 2(build 1031) and register the software

-Uninstall  VersaPro 1.0.

-Click "Yes to all" when prompted to delete files

-Install VersaPro 1.1_Nano Micro Edition

-On reboot, you will get a Windows error message: "At least one system or driver 
failed during system start up" However this doesn't effect the functionality of 
VersaPro 1.1_Nano Micro

Notes: On using Event viewer, it indicates that system start drivers failed to load Network XX.
However this doesn't effect the functionality of VersaPro 1.1_Nano Micro (Build 1150)

Resolution:  To avoid this problem, choose No to All when uninstalling VersaPro 1.0.

CR73114 VersaPro 1.0 appears non-functional if login profile used with Nano/Micro Edition
Details:

The Nano/Micro Edition stores user preferences, including the default hardware preference, in
a  user profile, which Windows often stores on a network.  Nano/Micro VersaPro sets this
hardware preference to Nano/Micro.  If a customer uses Nano/Micro VersaPro on one
computer, and then logs onto another computer on the same network that has VersaPro 1.0 --
then VersaPro 1.0 will appear to be non-functional.  Whenever the customer tries to create a
new folder, the hardware creation fails (because Nano/Micro is not supported by VersaPro
1.0), the New folder command does nothing and no error message is presented.

The same thing happens if the customer uninstalls VersaPro Nano/Micro and re-installs
VersaPro 1.0 on a single computer.

Resolution: The solution is for the user to go to the Tools Menu -> Options dialog in
VersaPro 1.0 and set the default hardware type to a 90-30 or VersaMax CPU.  VersaPro will
crash once on the creation of a new folder and after that it will function correctly.

CR73149 VersaPro 1.0 appears non-functional if login profile used with Nano/Micro Edition
Details:  If the Default Hardware Configuration was set to 90-30 Low End in VersaPro 1.0,
after upgrading to VersaPro 1.1, when you create a new folder, you will get the message
"Cannot Create Hardware configuration" and the folder will not be created.

Resolution:  Changing the Default Hardware Configuration setting fixes this problem. (From
the Tools menu, select Options. On the General tab in the Options dialog box, select a default
hardware type from the Default Hardware Configuration list.)

CR73136 VersaPro Install problem when logged onto a Novell network
Details:  When attempting to install VersaPro when also logged onto a Novell network, the
following errors will be reported:

RUNDLL has performed an illegal operation and will be shutdown

NWPOPUP has performed an illegal operation.......

MSGSRV32 " "

ESSVC " "

MNTASK " "

Installation aborted

Resolution:  You should re-boot the computer and not log onto a Novell network.  VersaPro
will then install successfully.
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LD Editor Issues:

ID Description

CR72315 Three rung ladder recognized as two rung ladder.
Details: The ladder below should be recognized as three rungs, not two.

Resolution:  Removing the wire between %I9 and %I10 creates 3 rungs.  In general, you
should avoid overlapping rows of logic.  In this particular example, you should move the
second rung down one row.

Continuation contact in LD missing plus sign with some fonts with Windows 95.
Details:  Open a folder that has rungs with continuation contacts.   Change LD display font to
Tahoma 10 pt. With focus in block, select File | Print, All, OK. The continuation contact in
will be missing the plus sign which makes it look like a regular coil.  Also, in Options, widen
the cell width a little (move the slider bar about 1/4 inch.).  With focus in block, select File |
Print, All, OK. The continuation coil will be missing a plus sign.

Resolution:  If continuation coils are needed, you should use the default font ( MS Serif).  The
defect does NOT occur with the default font and the fonts listed below:

Arial
Arial Black
Arial Narrow
Bookman Old Style
Comic Sans MS
Fixed Sys
Garamond
Haettenschweiler
Impact

Modern
MS Sans Serif
MS Serif
Small Fonts
System
Terminal
Times New Roman
Verdana

CR72316

The defect is known to occur with the following fonts and these fonts should be avoided when
using continuation contacts:

Courier
Tahoma

CR72637 Find Next (F3) does not Find Next the first time.
Resolution:  When using the F3 function key for the Find Next function, you may need to
press the key a second time to find the next occurrence.
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ID Description

CR72865 Cannot change data display type for instance variables in LD.
Details: Data display type for instance variables in LD cannot be changed when you click on
any cell but the top cell of the function block.  For example, place an ONDTR_HUNDS
instruction in a rung.  Store to PLC, start animation.  Select the function with the mouse but do
not click on the top cell of the function.  The default display format is displayed (decimal).
Select the right mouse.  Select Display Format menu and the following options are available :
Binary, Octal, Hexadecimal.  NOTE that the Unsigned and Signed Decimal items are grayed
out  and should be enabled.  Select one of the available options.

Nothing happens, display format remains the same.  This is not a problem in IL.

Another related issue occurs when trying to write to the function block instance variable. In
writing a value to the instance variable, if you do not click on the top cell of the function, the
value is not populated in the edit control.  Also, the address is highlighted rather than the value
(since the value is not present). You can still write a value to the correct address by typing to
the right of the colon.

Resolution:  You should select the functions by selecting the top cell of the function block to
get full access to formatting the display of and writing the value of the function blocks
instance variable.

CR72929 Program can be stored but not loaded back.
Details: In the following example (Example 1), the program can be stored but cannot be
loaded back because on the load VersaPro tries to put the function blocks in a straight line
which causes the last part of the rung to be beyond the 20 column limit.  You will see the
following error message: "An expression requires too much space and can't be displayed"
during the load from the PLC.

Resolution:  It is advised that rungs be constructed straight across to avoid this issue (see
Example 2).  If a very long single rung is needed, you should use the continuation coil.
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Example 1

Example 2
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LD Editor Issues (cont)

ID Description

CR73110 VersaPro does not accept max DINT value
Details:
The Series 90 Micro, VersaMax Nano/Micro and VersaMax CPUs allow a maximum constant
DINT value of 2147483866.  However, when a check-all is performed using this value, the
following error message is encountered:

---------- Checking folder: Timing_AddDInt. ----------

Checking block: _MAIN....
ERROR: [EQ_DINT] The constant '2147483866' does not match the operand type.
_MAIN - 1 error(s), 0 warning(s).

---------- Syntax check summary. ----------
Total errors: 1
Total warnings: 0

Resolution:  VersaPro 1.10 supports a maximum DINT value of 2147483647.  To avoid this
error, you should use a DINT value less than or equal to this value.

Password/OEM Key/Access Level Issues

ID Description

CR72614 Access Level 2 does not allow store of stored/override values.
Details:

1) Open any folder and connect to PLC

2) In status dialog, set access to level 2 (Write data level)

3) Do a store of Stored/Override values only

An error message will be presented "Store Error 0x0200-Insufficient Privilege Level"   Stored
values should be allowed at level 2 but  overrides require access level 3.  This is also an issue
with Logicmaster since it does not allow selection of stored values and overrides separately.

Resolution:  The access level must be set to level 3 or higher in order to store stored/override
values.

Print Issues

ID Description

CR71970 Printing to HP8000 Series Printer Does Not work on Windows 95/98.
Details:  When trying to print the information window to an HP8000 series printer, the
following error is reported: "A printer initialization error was encountered. Unable to execute
print command."  This is due to an HP printer driver problem.

Resolution:  You should use another printer with VersaPro until updated HP8000 printer
drivers are available that resolve the problem.  The other option is to use Windows NT if this
printer is required.
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Reference View Table (RVT) Issues:

ID Description

CR71698 Change RVT format to REAL, all values show 0.0.
Details: Change the RVT display format (for the whole table) to DWORD  REAL and all cells
go to a value of 0.0 even though other values were displayed before the format was changed.
The reason this occurs is that the RVT simply displays the Real interpretation of the same
binary value that was present when decimal format was being used.  It does not covert the
number because this would actually change the value of the binary, which you may not want
to do.

Resolution:  If a Real value is desired, you should first format the cell for real and then
directly enter the desired value.

Status Information Issues

ID Description

CR73115 VersaPro reports wrong amount of user memory space remaining on the CPU350 &
CPU36x CPUs.
Details:   The "Status Info" window displays the wrong amount of user memory space
remaining after a store of hardware configuration because the memory used by the hardware
configuration is not used to calculate the PLC memory usage.  The user program space is
based both on the logic memory size and the hardware configuration memory size.

Resolution:  To determine the actual logic memory available, you should subtract the
hardware configuration memory usage from the total reported by VersaPro in the Status Info
Window.  The hardware configuration memory usage can be approximately calculated by
adding the Data Size of each component under the Summary tab under the following selection
in hardware configuration:  Tools->Hardware Configuration Data View.  The Data Size is
presented in words.

Store/Load/Clear/Equality Issues

ID Description

CR71034 Failure to achieve logic equal after Load and verify of default program with VersaMax
Nano/Micro.
Details: Clear logic in PLC.  Load logic.  Verify logic but logic remains unequal.  Since the
logic is just loaded, the verify step should say that the logic is equal.

Resolution:   After loading an auto-configured VersaMax Nano/Micro, you should store the
program and configuration back to the PLC, which will cause the logic to be equal..
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ID Description

CR71325/
CR71929

Store problems after clear/load when using Ethernet module on 90-30 PLCs.
Details: VersaPro is connected to a 90-30 PLC via an Ethernet connection.

1) Clear hardware configuration or clear all on the PLC. Clear succeeds, you remain
connected.

2) Load hardware from the PLC. Load succeeds.

3) Open standalone HWC. The CMM 321 Ethernet module does not appear, a blank slot
appears in its place.  This is expected since the hardware configuration has been cleared.  The
Ethernet module should still communicate since it will keep its IP address.  However, the
clearing of hardware configuration will reset the Ethernet module making it unable to
communicate for a short period of time.

4) Store hardware configuration to the PLC. Fails with a "0x0005 Message not yet confirmed"
error.

Resolution:  Retry the store operation.  The Ethernet module should complete its reset cycle
and communicate again with the programmer.

CR71731 Logic does not become equal when stored to a series 90 Micro PLC.
Details: Store a folder to the PLC, but the logic does not become equal in the status bar.

Perform a verify of logic and it says Main.dec is equal but _Main.pdt is not equal. This results
in the inability to get real time updates in the LD editor.  However,  after loading the folder
back from the PLC into a temp folder, it was verified that the logic was indeed equal to what
had been stored from the previous folder and this time the status said the folder was equal.

Resolution:  The problem does not occur if a “Check All” is performed before storing the
folder.

CR71758 Load to a new folder Not equal.
Details:  When program, containing a variable declared  as a Bit in the VDT and used as a
word in the program, is loaded from PLC into a  new folder, .the logic does not show equal.

For example,

A bit variable declared, %M1, Length =1, Non-retentive in the VDT  is used on a contact

The variable is also used on an input to a BLK_CLR_WORD instruction, L=1.

The DEC file retentive state is generated from the VDT declaration and therefore sets only the
bit %M1 to non-retentive due to step #1.  When you load to a new folder, %M1, word, L=1,
non-retentive is declared in the VDT.  A word is declared in the VDT since this is the larger of
the two uses.   After a load, the folder is automatically recompiled.  This time %M1-%M16 are
all set to non-retentive in the DEC file. This is because a word is declared rather than a bit.
This will result in the folder going not equal with the PLC.

This will occur anytime you have declared a Variable as a non-retentive bit, has used the
address as both a bit and a word, and loads to a blank Folder.

Resolution:    To regain equality, you can do one of the following:

1) Change the variable declared back to a bit after the load operation.

2) Store the Folder back to the PLC

3) Anytime bit memory is used as both a word and a bit in logic, you should declare it as a
word in the VDT.
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ID Description

CR72183 Inequality after load due to Retentive Map issues.
Details: Create a small VersaPro program which contains an Add function and a COIL.  Use
%M00001 as the output of the Add function.  Set the retentiveness of this variable to non-
retentive.  Use %M00008 on the COIL.  Set the retentiveness of this variable to retentive.
Then delete the COIL.  The usage of the %M0008 variable should remain in the VDT.
Compile and store the program.  Create a new folder.  Load the program you just stored.
Notice the folder once the load is complete remains unequal.  The problem is the Retentive
Map is built based on the VDT.  The original folder had a usage of %M00008 which was
retentive so the bit was turned ON.  However, the second folder when the load was done did
not have this usage of %M0008 in its VDT.  There was also no usage of %M00008 in the
code, except for the implicit usage on the output of the ADD function which was set to non-
retentive.  Therefore, when the retentive map for the second folder was created the retentive
bit for the %M00008 bit was turned OFF.  Leaving the folder in the unequal state.

Resolution:  If the second folder created from the load from the PLC is stored and then loaded
the folder will remain equal with the PLC.

CR72406 After storing a folder, the status reads Logic Not Equal.
Details: With some folders created with VersaPro 1.0, the folder will intermittently be not
equal with the PLC after a store.  This is due to a problem in the file that indicates whether
blocks have changed and need to be sent to the PLC (smart store document <folder
name>.ssx)

Resolution:  Delete the smart store document “ <folder name>..ssx” located in the directory
where VersaPro is installed, compile the folder (check all) and the problem will be fixed.

CR72864 After loading LM90 folder into VersaPro through PLC verifies not equal.
Details:  Store a folder from LM90 to PLC and Load into a VersaPro folder and verify
equality. The Logic is not equal.  Although the execution of Logicmaster and VersaPro folders
is the same, the binary is slightly different which causes the inequality.

Resolution:   You should store the VersaPro folder back to the PLC which will cause equality.
Subsequent loads will also show equality.

Folder can’t be read after loading using PC with incorrect date
Details:  After loading from the PLC into a new folder on a PC with a pre-July 1998 system
date, the load occurs without error.  However when trying to open the folder, the following
error is received:  “Unable to open folder, unexpected file format”.

Resolution:   The dates on the files associated with the folder will have dates that are pre-July
1998 in this case.  VersaPro interprets these files as being stored in a different format.  In order
to correct the problem, you should set the computer system clock to the correct date and then
load the program from the PLC into a new folder.

Variable Import/Export Issues:

ID Description
CR70471 Variable import does not operate on SNF command.

Details: The variable import does not  act on the SNF command,
##&&DelVarDecl,ALLBLOCKS. There is no indication of an ERROR and the
variables are not deleted.
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VersaMax Nano/Micro Issues:

ID Description

CR71425 High Speed Counters should be disabled by default for VersaMax Nano/Micro PLCs.
Details:  When a new Hardware Configuration is made for the Nano/Micro PLC, all High
Speed counter channel function parameters are set to "Counter" by default. The channels
should actually be set to "Standard" by default, since during the PLC Auto-configuration the
High speed counter channels operate as Standard I/O.

Resolution:  If high speed counter operation is not desired, you can load the auto-
configuration from the PLC or set the counter channel function to standard.

CR72374 Store error for IL folder between 17.3 and 18K.
Details: Storing to a VersaMax Micro PLC an IL file that is greater than 17.3K but less than
18K, you may get disconnected from the PLC and the following error message is displayed
“Store Error.  0x6D02 – Unknown TargetComm Error”.  After storing a folder that is less than
17.3K, it stores fine.  Likewise, if you store an IL file greater than 18K, an error is expected
since this exceeds the Micro’s memory limits.  Also, if you store a ladder folder with a
program size between 17.3 and 18K, it stores fine.   The problem is due to the fact that the
PLC must do additional processing to compile the IL programs because IL programs internally
generate many Jump statements.  This processing takes additional time which causes the
communication link with the programmer to time out.

Resolution:  Increase the programmer default request time-outs from the default to 30 seconds
to give the PLC enough time to complete the processing of the large IL program.

CR72878 Invalid Hardware Config is not reported if there is a logic store error on VersaMax
Nano.
Details: When attempting to store an invalid Hardware Configuration with Logic, you only
receive a Logic Error.  The Invalid Hardware Configuration error is masked/not displayed.

Steps to reproduce:
1.  Invoke VersaPro.  Open a folder containing the default Nano/Micro CPU, which is a Micro
(UDR005).  Connect to a VersaMax Nano, NDR001.

2.  Create a Ladder/Instruction List Block.  Place no logic in this block.

3. Store hardware config and logic.  (Actual CPU is Nano, and CPU in folder is a Micro).

4. Hardware is stored with no errors as displayed in Information window, then attempt to store
logic fails giving the following error message: "Store Error:  0X0591 - Program is too large."

Expected Results:  In the information window, the error "Config not valid" should appear
when attempting to store the Hardware Configuration.  After attempts to store Hardware
Config fail, should exit store attempts.

Resolution:  The problem can be avoided by storing HW Config separate from Logic.  This
will confirm whether there is a hardware configuration issue.

CR72856 Verify of %AI fails after perform a successful Store and Load on VersaMax Micro.
Details: Verify for %AI reference tables fail after performing a successful Store and Load
operation on H/W, Logic and Stored/Override values, of a VersaMax Micro PLC because the
potentiometer (analog timers) on the Nano/Micro (including Series 90 Micro) control the
values at %AI0016 and %AI0017.  The values of these locations will change slightly due to
slight variations in the analog signal created by the potentiometers to the A to D converter in
the Nano/Micro.

Resolution:  To avoid the verification failure, do not select verification of stored/override
values when using the Nano/Micro.  Verification of stored values can be achieved by
manually observing reference table values in RVT when on-line.


